Home Wiki > SDB:KDE installatiebronnen
Sign up | Login

This wiki has been moved and updated recently. If you encounter any issue, please let us know by mail to admin@opensuse.org.

(Doorverwezen vanaf KDE repositories)

SDB:KDE installatiebronnen

tagline: Uit openSUSE

Deze pagina catalogiseert en beschrijft de beschikbare KDE installatiebronnen en verschaft links ernaar. Geen van hen wordt officieel ondersteund.
Waarschuwing: Vermijd het mengen van installatiebronnen die toebehoren aan verschillende versies van KDE (Stabiel/Factory/Onstabiel/...).

Achtergrond

De opzet van de installatiebronnen is gebaseerd op het onderscheid tussen twee groepen pakketten, namelijk:

  • Op KDE SC gebaseerde pakketten. Deze groep bevat de "Plasma Workspace", de hoofdbiblotheken van KDE, maar ook toepassingen zoals KMail, Konqueror, etc.
  • Pakketten voor op KDE/Qt gebaseerde toepassingen. Deze groep bevat toepassingen gebaseerd op de KDE of Qt biblotheken, zoals Amarok, Konversation, Quassel, etc.

Updates voor onderhoud

Sinds openSUSE 12.3 biedt het gemeenschapsteam van openSUSE voor KDE nieuwe minor versies van de KDE Software Compilation, die is meegeleverd met de laatste stabiele distributie, via updates voor onderhoud. Dit betekent dat minor KDE software uitgaven voor de laatste openSUSE versie geleverd worden zonder de noodzaak van extra installatiebronnen. Dit wordt weerspiegeld in de manier waarop de installatiebronnen voor KDE zijn opgezet.

Op dit moment hebben we het volgende voor onderhoud:

openSUSE 12.3: geleverd met KDE SC 4.10 en updates voor onderhoud worden tot KDE SC 4.10.5 geleverd. De pakketten worden gebouwd in de installatiebron KDE:Release:410. Gegeven de updates voor onderhoud, wordt de installatiebron KDE:Release:410 zelf niet voor openSUSE 12.3 geboden.

openSUSE 13.1: wordt geleverd met KDE SC 4.11.2 en updates voor onderhoud zullen geleverd worden via het normale kanaal voor updates. De pakketten worden gebouwd in de installatiebron KDE:Release:411 en daarom wordt de installatiebron KDE:Release:411 zelf voor openSUSE 13.1 niet geleverd.

Wat is er beschikbaar

Gebaseerd op wat hierboven is aangegeven, zijn de volgende installatiebronnen beschikbaar gesteld aan de gebruikers van openSUSE.

Voor gebruikers

  • Bijgewerkte KDE Software Compilatie uitgaven
    Dit zijn nieuwere versies van de KDE SC zoals uitgegeven door de KDE gemeenschap, plus openSUSE patches (uitgegeven en niet uitgegeven). Ook beschikbaar voor oudere versies van openSUSE. Deze pakketten worden onderhouden door het KDE team.
  • KDE Extra
    Nieuwere versies van individuele KDE toepassingen uit openSUSE Factory, waar pakketten van gemaakt zijn voor vrijgegeven distributies. U hoeft KDE niet ook op te waarderen, maar het mag wel, omdat KDE voorwaarts compatibel is.

Voor hen die bijdragen

  • KDE Onstabiel Extra
    Alpha's, beta's en SCM snapshots van KDE toepassingen die onder ontwikkeling zijn. Deze wordt alleen gebouwd voor de laatste openSUSE uitgave vanwege mogelijke afhankelijkheden van nieuwere pakketten.
  • KDE Onstabiel SC
    SCM snapshots van de volgende KDE SC uitgave en tegelijk de speeltuin voor ontwikkeling van het gemeenschapsteam van openSUSE voor KDE.

Ik wil...


Alleen bijgewerkte toepassingen

Als u de officiële, ondersteunde en geteste KDE kernpakketten gebruikt geleverd met de distributie, dan zijn dit extra installatiebronnen om te overwegen deze te gebruiken.


Upstream aka. KR411 (KDE SC 4.11)

De laatste stabiele puntuitgave van KDE SC 4.11. Gebruik deze installatiebronnen, als uw de laatste versie van KDE wilt gebruiken. Zoals aangegeven worden voor KDE SC 4.11 de bijgewerkte pakketten aan de gebruikers geleverd in de openSUSE 13.1 installatiebron voor het bijwerken (oss-update). Voor gebruikers van openSUSE 13.1 is het niet nodig om deze specifieke installatiebron te activeren.

Waarschuwing: Verwijder alle installatiebronnen uit de secties Alleen bijgewerkte toepassingen als u KR411 gaat gebruiken.

Vorige KDE SC uitgaven

Gebruik deze installatiebronnen als u een een vorige uitgave van openSUSE gebruikt.

Waarschuwing: Verwijder alle installatiebronnen uit de sectie Alleen bijgewerkte toepassingen (Extra) als u KR410 gaat gebruiken.

Dit artikel is nog maar gedeeltelijk vertaald. Als u mee wilt helpen met vertalen lees dan Wiki vertalen naar het Nederlands.

Factory aka. KDF (KDE SC 4.11)

This repository features the KDE packages under development for the upcoming openSUSE release. This repository is normally only build for openSUSE:Factory, however in preparation of a newer KDE release (and corresponding KR repository), it will also be build for the latest openSUSE release.

As indicated the below repositories will only become available when a new KDE SC Beta release is being build.


Unstable:SC aka. KUSC (KDE trunk)

Waarschuwing: Not for production use. Untested, experimental, unreleased.

Snapshots of KDE trunk. Updates are provided on a regular basis for those packages that received upstream changes. These packages may not always include openSUSE specific patches, and are only available for 64-bit versions of the latest openSUSE release and openSUSE Factory.

The team is also using this repository to test new patches, new packaging methods and other things that could cause a temporary breakage in the KDE installation. This repository should only be used by experienced users that understand and accept the risks coming with the usage of this repository. Also bug reports are not accepted for this repository.


KDE Frameworks 5

Waarschuwing: KDE Frameworks 5 is now in pre-alpha stage and it is not meant for end users. This is for developers only.

Snapshots of KDE Frameworks 5 and Qt 5.2 trunk. These packages are coinstallable with KDE SC 4 and Qt 4.


KDE 3.5.10

This is the latest KDE 3 release packaged for released distributions. See separate page for explanation and repositories.


Qt

Waarschuwing: You do not need to add these if you are using the KDE repositories listed above. The repositories already include the correct Qt packages.

Qt 4 release

Qt 4.x.x version that is currently being considered most stable while being reasonably recent. Not needed if you use KDE:Distro:Factory or KDE:Distro:Stable.

Qt 4.8 Development Snapshots

For developers only

Qt 4.7 Development Snapshots

For developers only

Qt 5 release

Latest stable Qt5 release (currently 5.2.0 beta1)

Qt 5.2 Development Snapshots

For developers only These snapshots are from gitorious, stable branch

Qt 5.3 Development Snapshots

For developers only These snapshots are from gitorious, dev branch -- this repo is not yet functional


Building your own software using Qt or KDE

To build your own packages against either KDE 4.x or Qt 4.x, choose one of the following repositories as a base to build against (When adding a repository, click on "Advanced" at the bottom and then select the repository name in the item list):

  • KDE:Qt if you want to build a Qt-only application against a stable Qt 4.x release. This repository currently features Qt 4.8.x
  • KDE:Qt48 if you want Qt 4.8.x.
  • KDE:Release:<KDE SC release> if you want to build a KDE 4.x application against KDE 4.8.5. for any of the released openSUSE releases.
  • KDE:Distro:Factory if you want to build a KDE 4.x application against KDE 4.9.x for any of the released openSUSE releases.

Zie ook