Home Wiki > Gids voor printer aanschaffen
Sign up | Login

Gids voor printer aanschaffen

tagline: Uit openSUSE


Een printer kopen

De eerste plek om informatie over het ondersteuningsniveau van een printer te krijgen is de printerdatabase op www.linuxprinting.org. U hebt de details nodig over de printerfabrikant en het precieze model. Bijvoorbeeld, een zoekopdracht voor "Kyocera Mita"/"FS-820" verschilt met "Kyocera Mita"/"F-820".

Onthoud bovendien dat perfect werkende laserprinters vaak tweedehands verkrijgbaar zijn voor maar 25 euro, incl toner. Zoals bijvoorbeeld de Kyocera Mita 1700 en HP Laserjet5m.

PostScriptprinters

PostScriptprinters leveren de minste problemen op en zijn daarom het meest aanbevolen.

(Echte) PostScriptprinters en emulatie

Er zijn 2 soorten Postscriptprinters: printers met het handelsmerklogo van PostScript en printers die PostScript emuleren. Het verschil is de prijs: het kost veel geld om het PostScriptlogo te mogen gebruiken, wat de printer een stuk duurder in prijs maakt. De originele PostScript-lettertypen zijn bij de officiële PostScriptprinters bijgesloten.

Verzeker u ervan dat er een DDP (PostScript Printer Description) bestand voor de printer beschikbaar is. Als dat het geval is, dan is het simpel om de printer aan uw afdrukssysteem toe te voegen en gebruik te maken van geavanceerde functies, zoals dubbelzijdig afdrukken of verschillende resoluties.

PostScriptversie

Een nadeel van oude PostScriptprinters (postScript-level 2 of minder) is dat ze niet in staat zijn multi-byte lettertekens af te drukken. Deze multi-byte lettertekens zijn nodig voor het afdrukken van speciale tekens, zoals die van Aziatische talen. Voor zover bij mij bekend is er geen manier om op beide manieren af te drukken. Het resultaat is: als u een PostScript-level 2 hebt, dan moeten de gegevens eerst worden omgezet. Met als gevolg dat de geavanceerde functies van de printer, zoals dubbelzijdig afdrukken, niet langer beschikbaar zijn.

Niet-PostScriptprinters

Niet-Postscriptprinters zijn meestal inkjetprinters.


HP Inkjet-project

Printers van Hewlett-Packard (HP) worden ondersteund door opensource Linux-stuurprogramma's die door het bedrijf zelf worden ontwikkeld. We adviseren dus dit merk printers te gebruiken met openSUSE/SUSE Linux. U kunt de nieuwste stuurprogramma's downloaden bij het [HP Linux Printing Project]. openSUSE probeert altijd de nieuwste stuurprogramma's mee te leveren, maar door de tijd die nodig is om een distributie te bouwen kan het gebeuren dat het meegeleverde stuurprogramma niet de meestrecente versie is.

Prijzen

HP-printers zijn over het algemeen iets duurder. Maar u zult geen problemen ondervinden bij het verkrijgen van mooie afdrukken van deze printers, wat bij andere printers mogelijk wel het geval is. Ze worden ondersteund door het bedrijf zelf, en als HP een wijziging aanbrengt in de manier waarop hun printers worden aangestuurd brengen ze een nieuwe versie van het stuurprogramma uit. En de Linux-klant krijgt ondersteuning.

Als u een printer koopt, dan dient u ook de totale kosten van het apparaat te berekenen. Dit is inclusief de vervangende toners (inkt), drumkits, inkcartridgets, hoe eenvoudig u vervangers kunt verkrijgen, etc. Als u al deze kosten bij elkaar optelt zult u merken dat de kosten van een HP-printer opeens vergelijkbaar is met modellen van andere fabrikanten.

Ik adviseer HP Business Inkjets. Ze zijn wat duurder, maar u koopt dan een stuk hardware dat u niet hoeft weg te gooien nadat de tweede inktnavulling is gekocht.

Printers met niet-opensource Linux-stuurprogramma's

Momenteel is er geen ander bedrijf bekend dat bereid is om opensource-stuurprogramma's aan te leveren. Sommige fabrikanten leveren wel Linux-stuurprogramma's, maar die zijn dan niet opensource. openSUSE kan deze niet aanpassen om ze werkend te krijgen. :-( Dat is zeer frustrerend, als fabrikanten er opeens achter komen dat AMD64 bestaat, welke in staat is om 32bit-code en 64-bit code te draaien. Vanwege dat feit is het openSUSE-systeem anders opgezet om beide schema's te ondersteunen. Maar de fabrikanten met niet-opensource stuurprogramma's realiseerden zich dit in een zeer laat stadium, als ze dat al hebben gedaan. Dus u kunt tegen problemen aanlopen die niet door de fabrikanten van niet-opensource stuurprogramma's zijn voorzien.

Een ander probleem van deze niet-opensource stuurprogramma's is dat, wanneer er bijv. een veiligheidslek wordt ontdekt, u moet wachten totdat de fabrikant dit probleem heeft erkend, gerepareerd, getest, en dan na enige tijd een update uitbrengt.

Bekende fabrikanten zijn: Brother, Epson.

Windows- / GDI-printers

Probeer ze niet! Het is zeer onwaarschijnlijk dat deze printers goed zullen werken onder Linux. Voor enkele verouderde printers zijn er enkele filters beschikbaar (zoals Lexmark Z11), maar niet voor de nieuwste modellen. In het verleden is het vaak gebeurd dat de opensource-gemeenschap een manier had gevonden om dit type printers te ondersteunen, maar dat enkele weken later de fabrikant met een nieuw opvolgend model kwam dat een ander protocol gebruikte, waardoor er weer een nieuw stuurprogramma nodig was. Dus zelfs als er een stuurprogramma voor een GDI-printer beschikbaar is, dan is de kans groot dat die niet werkt bij het volgende model.

Bekende fabrikant van dit type printers is: Lexmark.

Samenvatting

Samenvatting: koop een PostScriptprinter, met PostScript-level 3. Als u dat niet kunt doen, koop dan een HP inkjet, zoals een Business Inkjet, en alles zou eenvoudig moeten werken.

Zie ook

Lijst met ondersteunde printers

Printerconfiguratie (CUPS, YaST-printermodule)

Externe koppelingen

Linux Printing-project


Klaus Singvogel, Kssingvo, 16:08, 30 nov 2005 (CET)